Duplice versione di php7.0 e php5.6 su Debian Stretch

Duplice versione di php7.0 e php5.6 su Debian Stretch

Duplice versione di php7.0 e php5.6 su Debian Stretch

Con l'uscita dell'ultima stable Debian 9 Stretch, la versione di php di default è la 7.0, ma sarebbe utile avere a disposizione anche la versione 5.6. Per averle entrambe la strada più semplice è quella di aggiungere i repository deb.sury.org:

# curl https://packages.sury.org/php/apt.gpg | apt-key add -
# echo 'deb https://packages.sury.org/php/ stretch main' > /etc/apt/sources.list.d/deb.sury.org.list
# apt update

per verificare la versione di php:

# php -v

per cambiare versione:

# update-alternatives --config php

Duplice versione di php7.0 e php5.6 su Debian Stretch

enjoy 😉

 

Post simili (quasi):

4 pensieri riguardo “Duplice versione di php7.0 e php5.6 su Debian Stretch”

  1. Google Chrome 61.0.3163.100 Google Chrome 61.0.3163.100 Mac OS X  10.11.6 Mac OS X 10.11.6
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

    Ciao

    Io la 5.6 dovrei installarla in modo da farla funzionare sotto ISPCONFIG 3.1 ma sul sito del pannello di controllo non trovo alcuna guida utile a tal scopo: https://www.ispconfig.org/documentation/ alla voce "Using multiple PHP versions"

    La necessità è che mi sono accorto che molti siti in Joomla 2.5 hanno problemi a girare con la versione 7 di PHP.

     

    Puoi suggerirmi qualcosa?

     

    Grazie

     

  2. Safari 10.1.2 Safari 10.1.2 Mac OS X  10.12.6 Mac OS X 10.12.6
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8

    Se usi Debian Stretch, puoi seguire questa guida oppure aggiungi i repo di Debian Jessie. Ancora php7 non è supportato completamente da tutti

  3. Google Chrome 61.0.3163.100 Google Chrome 61.0.3163.100 Mac OS X  10.11.6 Mac OS X 10.11.6
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

    Guarda, ho seguito la guida e l'ultimo 

    # apt update

    mi ha riportato una derie di errori

     

     

    Adesso mi da questo errore

    # apt-get update

    E: Malformed line 1 in source list /etc/apt/sources.list.d/php.list (type)

    E: The list of sources could not be read.

  4. Firefox 55.0 Firefox 55.0 GNU/Linux x64 GNU/Linux x64
    Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

    i repo adesso sembrano non funzionare 🙁

    in alternativa

    echo 'deb http://ftp.it.debian.org/debian/ jessie main' > /etc/apt/sources.list.d/jessie-php5.list

    installi php5 e poi commenti il repository

     

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *